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1 Introduction 
3D DataManager, consists of two modules. The first, 3D DataManager Extractor, is 
designed to export a SmartPlant 3D database into a Microsoft Access file, containing 
one table per task. The resulting records are compressed and internally resolved by code 
lists. The Access file serves as a base for the second module, the 3D DataManager user 
interface, used to create Reports with simple drag ’n drop operations. 

Additionally, 3D DataManager is divided into two versions. The 3D DataManager 
Reporter utility is primarily used for reporting, while the other version, the 3D Data-
Manager Pro Extends the Reporter version with the ability to change Data and write 
the changes back to Intergraph’s SmartPlant® 3D 

1.1 General conventions 
This document contains many visual cues to help you understand the meaning of certain 
words or phrases. The use of different fonts for different types of information allows 
you to scan the document for key concepts or commands. Symbols help abbreviate and 
identify commonly used words, phrases, or groups of related information 

Typefaces 
Italic Indicates a system response, which is an explanation of 

what the software is doing. For example,  
 
The text is placed in the viewing plane. 

Bold Indicates a command name, parameter name, or dialog 
box title. Command paths are shown using an arrow be-
tween command names. For example, 

 Choose File → Open to load a new file. 

Sans serif Indicates a system prompt or message, which requires an 
action be taken by the user. For example,  
 
Select first segment of alignment 

Normal typewriter 
Indicates an actual file or directory name. For example,  
 
The ASCII report is stored in the layout.rpt file. 

Bold typewriter 
Indicates what you literally type in. For example,  
 
Key in original.dat to load the ASCII file. 
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Symbols 
This document uses the following symbols to identify special information: 

 Note – important supplemental information. 

 

 Map or path – shows you how to get to a specific command or form. 

 

 More information – indicates there is additional or related information. 
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2 Installation 
Requirements: 

• Operating system: Windows 2000 SP4/XP/2003/Vista 

• Intergraph SmartPlant 3D SP5 or later 

Administrator rights are required on each computer to install CAXperts 3D DataMan-
ager. “Run as” is not supported. 

2.1 License 
There are three different licenses which enables the following features: 

Feature ReviewManager 
Extractor 

3D DataManager 
Extractor 

3D DataManager 
Pro Extractor 

Extract Piping + + + 
Extract Equipment + + + 
Extract Structural + + + 
Extract Electrical + + + 
Extract HVAC + + + 
Extract Piping 
Catalog 

- + + 

Extract labels - - + 
Create SmartPlant 
Review Session 

+ - + 

Calculate esti-
mated length, vol-
ume, surface 

- - + 

Report Connected 
objects 

- - + 

Merge databases - - + 
Execution of  SQL 
statements 

- - + 

Once the setup has been completed, and the program is started, a license key will be re-
quested, as shown below. 
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 Note: Without a valid license the software works in demo mode. 

 Note: As seen above the domain name is required in order to generate a 
license key. 3D DataManager can then be used with the same license key 
on all computers in the same domain. 

If the installed license needs to be updated (i.e. evaluation license) select Update li-
cense… from the Help menu. The dialog box shown above will be displayed again. 
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3 3D DataManager Extractor 
The 3D DataManager Extractor is used to extract SmartPlant 3D data out of an ex-
isting project. This can either data be the Material-Take-Off (MTO) of all SmartPlant 
3D disciplines or Piping Catalog Data. The extraction of all data can be done without 
any knowledge of SP3D specific Report Creation. The philosophy is to use the  
SmartPlant 3D Workspace Filters for creation of discipline specific reports. 

 Note: 3D DataManager Extractor requires SmartPlant 3D and a Smart-
Plant 3D (S3D) license seat on a SmartPlant License Server. 

3.1 Setting up 3D DataManager Extractor 

Extracting MTO-Data 
Start 3D DataManager Extractor and select your Model Plant from the Combo Box:  

 

 Note: Only plants of the current site are displayed. 
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From your Smart Plant 3D Project all personal and Plant Filters are shown and each can 
be used for Extraction. 

 Note: For each task individual filters can be applied. 

Browse with the ( ) button to select a location to create a Microsoft Access Data-
base file in which the results will be shown. 

 

Force extraction – By default this option is disabled (recommended). When disabled, 
the software only processes changed objects since the last. The data of the last extrac-
tion is stored in *.3dm file which is password protected and located in the same direc-
tory as result access database. If the *.3dm file doesn’t exist or the force extraction 
switch is enabled, all objects will be fully extracted from SmartPlant 3D. 

 Note: Force extraction switch has no effect on the Piping Catalog task. 

Create SmartPlant Review session- See “Create SmartPlant Review session” 

All the settings are stored automatically in the configuration file which is found under 
Tools>Settings. 

Start the process by clicking the Extract button. 
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 Note: To modify or add new attributes to the resulting access database 
see “Configure Attributes” 

Extracting Piping Catalog Data 
3D DataManager Extractor also allows extraction of Piping Catalog Data.  

This enables customers to check the content of Piping Specs in a very efficient way. 
It’s an important benefit to have all Attributes of each PipeSpec part in one table of your 
DB instead of having all the information in different Excel-sheets and -workbooks. Ad-
ditionally all code list-values appear with their description, not only with their numbers. 

 

 

Start the process by clicking the Extract button. 

 Note: To modify or add new attributes to result Access database see 
“Configure Attributes” 

3.2 Create SmartPlant Review session 
3D DataManager Extractor allows creation of a Smart Plant Review session which 
can be viewed in the CAXperts ReviewManager or in SmartPlant Review.  

If the checkbox Create SmartPlant Review session is enabled the software creates 
SmartPlant Review *.vue file containing the graphical objects from selected tasks (ac-
cording to the applied filter) and the SmartPlant Review database (*.mdb2) with at-
tributes as configured in the “Configure Attributes” menu  
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 Note: *.vue file can be opened in SmartPlant Review 6.2 or higher.  

 Note: The *.xml file containing attributes for SmartPlant Review ses-
sions, which are typically created upon creation of a SmartPlant Review in 
SmartPlant 3D, is not required and not generated, because all the attributes 
for the objects contained inside of the *.vue file are stored directly in the 
SmartPlant Review database (*.mdb2). 

3.3 Configure Attributes 
3D DataManager Extractor contains a predefined set of attributes which are reported 
by default. Additionally customer can define and configure own attributes. No database 
specific or programming knowledge is required for customization of reportable Smart 
Plant 3D attributes. 
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Add new attribute 
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Press OK to finish the configuration.  

 Note: The changes will be applied on the next extraction 

 Note: SmartPlant 3D labels can be used similar to the direct object at-
tributes. 

Different attributes can be mapped to a single column as shown above. The attribute that 
fits to the object type in the current row will be shown. A single column can be removed 
or renamed by selecting the necessary option in the context menu which is opened by 
right clicking on a node. The attributes which belong to an object type are listed by ex-
panding the relative object type node. Dragging a single attribute node and dropping it 
on the (task/table) main node on the right side will map the object to the column. 
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Mapping one or more objects to columns can be done by dragging and dropping a se-
lected object in to the target column. 

If you expand the column node in the right tree, you will see all the object variations 
which the column cells can contain. 

 

Extended attribute settings 
Click with the right mouse button on a code listed attribute to open extended attribute 
configuration form: 

 

Code listed attributes can be extracted as: 

• Numeric values 

• Values decoded by short description 

• Values decoded by long description (default) 

 

 Note: The changes will be applied on the next extraction. 
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Find 
Select “Find…” from the Edit menu to search for the available attributes: 

 

Enter the search text in “Find what” and define the task name in “Look in” to search 
for the attribute in the given task: 

 

3.4 Configure Units 
3D DataManager Extractor allows to configure the units and their decimal precision 
independently of actual Smart Plant 3D settings. 

 

• Unit Type – Unit of Measure description 
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• Unit – Measuring unit abbreviation 

• Decimal Precision – Decimal precision to format the value (decimal 
count) 

• Leading Zero – Enable leading zero to format the value 

• Trailing Zeros –Enable trailing zeros to format the value 

 Note: The changes will be applied on the next extraction 

3.5 Settings 
All program settings (selected tasks and filters, attributes, units of measure …) are 
stored automatically for each plant in the configuration file located by default in the user 
profile folder. The location of the configuration file can be changed by using menu 
Tools->Settings. 

Load settings from file 
To import the settings into the plant configuration file use menu “File->Load settings 
from file”. 

 Note: The location of the plant configuration file is not 
affected, only the content of the file will be overwritten 

Save settings to file 
To export the settings from the plant configuration file use menu “File->Save settings to 
file”. 

 Note: The location of the plant configuration file is not 
affected 

3.6 Merge databases 
Select “Merge databases…” from the Tools menu to merge multiple 3D DataMan-
ager Extractor Access Databases with Piping Catalog data into single database. 
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 Note: the merge function supports only the Piping Catalog task. 

3.7 Content of result database 
When extraction process has finished, 3D DataManager Extractor prompts for open-
ing the resulting database in Microsoft Access. 

There are some sample reports for Piping and Equipment with typical task-specific at-
tributes predefined. These reports can also be used as templates to create other reports. 

The philosophy of 3D DataManager Extractor is to have one table with all attributes 
per Task on the hierarchy-level of parts. 
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Piping Catalog 
The table contains the following objects: 

• Pipes 

• Pipe Components 

• Pipe Bolt Set 

• Pipe Gaskets 

• Pipe Nuts 

• Pipe Washers 

Piping 
The table contains the following objects: 

• Pipe Part 

• Pipe Component 

• Implied Part Occurrence 

• Pipe Instrument 

• Pipe Specialty Item 

Pipe Bolt Set • 

Pipe Weld •

• 

s 

nents 

 

Pipe Gasket 

• Pipe Support

• Support Compo

 Note: The length, surface area and volume attribute are estimated values 
th  at are calculated using basic mathematical formulas. These values are only
estimates and should only be used as a reference. 

Equipment 
The Equipment table contains one row for each nozzle and one additional row for each 

The table contains the following objects: 

• Equipment 

omponent 

Equipment/Equipment Component without any nozzles as shown below: 

• Equipment C

• All Type of Nozzles 
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Structural 
The table contains the following objects: 

• Member Part Prismatic 

• Member Part Curve 

• Ladder 

• Stair 

• Handrail 

• Assembly Connection 

• Footing Component 

• Slab 

HVAC 
The table contains the following object: 

• Duct Component 

Electrical 
The table contains the following objects: 

• Cable Tray Component 

• Cable Tray Part 

Cableway • 

Plant 
The table includes the information about the plant and database. 
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3.8 Command Line Mode 
The 3D DataManager Extractor can be used from the command line to automate the 
exportation of a SmartPlant 3D data. 

To then open the 3D DataManager Extractor batch mode help type in the installation 
path of 3D DataManager followed by “\3D DataManager Extractor.exe” /?. 

 
"3D DataManager Extractor.exe" [/plant plant_name] 
[/config config_file.ini] [/output output_file.mdb] 
[/task Piping [/filter area1]] [/task Piping Catalog 
[/filter spec1] [/filter spec2]] [/force] [/createSPR] 

 

/plant plant_name SmartPlant 3D plant to process 

/config config_file.ini Config file which contains the settings for the extrac-
tion. If a configuration file is not defined, the last con-
figuration will be used 

/output output_file.mdb Output database. If Output database is not defined, the 
last configuration will be used 

/task task_name Task name to extract, followed by the filter. If no tasks 
are defined, the last configuration will be used 

/filter filter_name Filter name, applied to the previously defined task. 
Multiple filters can be defined for Piping Catalog task 

/force Force extraction, see “Extracting MTO-Data” for de-
tails” 

/createSPR Create SmartPlant Review session, see “Create 
SmartPlant Review session” for details 
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